icos - new security requirement

 

Dear Sir or Madam,

in order to ensure to provide further on an optimal protection against attacks from the Internet, we will increase our security level on 27th/28th January 2017 (following BSI recommendations). It involves the encrypted data exchange (SSL, version TLS 1.0 to TLS 1.1 and higher) when using ICOS and the igefa e-shop.

As a result, ICOS and the igefa e-shop can no longer be accessed with older browsers.

This concerns in particular:

- Internet Explorer 6
- Internet Explorer 7
- Mozilla Firefox less than version 34
- Google Chrome less than 26

Users of Windows XP must install Service Pack 3 (SP3) and Internet Explorer 8 or Firefox 34 (or higher) or Chrome 26 (or higher). We would like to point out that, if necessary, the encryption protocol TLS1.1 or TLS1.2 must be activated.

For the use of ICOS mobile you need at least a smartphone with:

- Android 4.3 or higher,
- iPhone with iOS 7 or higher,
- Windows Phone 8.1 or higher,
- Blackberry 10.2.5 or higher.

In order to ensure the above mentioned system requirements, please contact your IT / IT service provider in a timely manner.